DIY - Effective Home Recording Strategies with Tools
POWERPOINT NARRATED SLIDES SCENARIO

Description: The instructor’s voice is heard over a slideshow, but the instructor is not seen.
When you record a narration, you run through the presentation and you record a message on each slide.
You can pause and resume recording. In Normal view, select the slide that you want to start the
recording on. You can use the following software:
PowerPoint
Camtasia
QuickTime Mac native
Kaltura
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Scenario 2: Record a Full-Screen Lecture (Narrated Slides) – PowerPoint
Software:
PowerPoint
Hardware:
Mic
Camera
PC Computer

Platform:
Windows
Tablet:(unable to test)

Cost:
Free, ODU Office 365

Prepare
Your
Content!

Here are some tips to help you record a full screen lecture video for your class:
Chunk your lecture into short 5 to 10 minute segments. Not only are shorter
videos easier for you to upload, but people also have shorter attention spans
online.
Observe copyright laws for both images and text content. Use Creative
Commons for restriction-free images.
For visual accessibility, be sure you have good color contrast between your
background and fonts.
Don’t use background images.
Choose large, legible fonts: stick with sans-serif fonts (Calibri or Arial instead of
Times New Roman, e.g.) and use 20-40pt sizes that are easy to read. Bold and
italics should be used for emphasis only. ALL CAPS is reserved for acronyms.
When designing slides, use the 7x7 Rule: no more than seven lines, with seven
words across. Keep slide designs clean. Follow a logical sequence in your
content.
Plan your scripts ahead of time. Speak clearly.
Practice, practice, practice!

Where to
download
What to do

ODU Software Services

How to
install
How to use
Step 1

Installation Guide

Step 2

#1 This will minimize everything and will add a toolbar to the top of your screen. You
can record your entire screen, or you can select a particular portion of it by choosing

Use 1: Record full screen lecture

Open a Microsoft PowerPoint presentation and go to the Insert tab. At the far right, on
the media set of tools, click the Screen Recording button.
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the “Select Area” button. You can also include a voiceover. It’s enabled by default, and
you have the option to include or to exclude the cursor from appearing in the
screencast. When you’re ready to record, click the Record button on the toolbar.

#2 You get a brief countdown before the recording begins, and PowerPoint will tell you
that you can end the recording with the Win+Shift+Q keyboard shortcut.

#3 Once you finish recording, the screencast is automatically added to the PowerPoint
presentations.
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Step 3

Finish Recording
If you want, you can export it to your desktop. Right-click the screencast and select the
Save media as option. Select the place where you want to save it, and you can insert it
into your course.

Step 4

PowerPoint itself has a few very basic video editing tools that allow you to crop a
video, add a few transition effects, insert captions, and trim the video.
There is no way to separate the audio from the video file. Even if you record a voice
over separately, PowerPoint doesn’t have an option to add an audio track to the video
file. However, you can send both the screencast video and the audio files to CLT, and
CLT will assemble them for you. If you record audio as part of your screen recording,
CLT can also separate the audio from the video, if they need to be edited separately.

Step 5

The screencast is saved as an MP4 file which all media players and video editing
applications can play.

Tips and Tricks

New Features (2019)
•
•
•
•
•
•
•
•
•
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Transition Morph.
The Zoom - The Summary zoom, The
Section zoom, The Slide zoom.
Insert Icons and 3D models.
Add an Online Video.
Convert to High-Quality Videos.
Digital Control, etc.
Text Highlighter
SVG images
The 10 PowerPoint New Features

Pros

Design
•

Quick and easy: the basic features are
easy to master and they can make you
appear to be organized, even if you are
not.
• Simple bullet points: it can reduce
complicated messages to simple bullet
points. Bullet points are a good basis
for a presentation, and they remind
the speaker of main points and the
organization of the message.
• Easy to create a colorful, attractive
design: using the standard templates
and themes, you can create something
visually appealing, even if you do not
have much knowledge of basic graphic
design principles.
• Easy to modify: when compared to
other visual aids, such as charts,
posters, or objects, it is easy to modify.
• Easy to re-order presentation: with a
simple drag and drop or using
keystrokes, you can move slides to reorder the presentation.
• Finally, PowerPoint is integrated with
other products that allow you to
include parts of documents, spread
sheets, and graphics.
Delivery
•

•

•
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Audience Size: PowerPoint slides are
generally easier to see by a large
audience, when projected, than other
visual aids.
Easy to present: you can easily advance
the slides in the presentation one after
another with a simple key stroke while
still maintaining eye contact with the
audience.
No need for Handouts: they look good
visually and can be easily read, if you
have a projector and screen that is
large enough for the entire room.

Cons

Design
•

Design power pointless: gives the
illusion of content and coherence,
when in fact there is really not much
substance or connection between the
different points on the slides.
• PowerPoint excess: some speakers
create presentations so that they have
slides to present rather than outlining,
organizing, and focusing on the
message.
• Replaces planning and preparation:
PowerPoint is a convenient prop for
poor speakers, as it can reduce
complicated messages to simple bullet
points and it can elevate style over
substance.
• Oversimplification of topic: the linear
nature of PowerPoint forces the
presenter to reduce complex subjects
to a set of bullet items that can be too
weak to support decision-making or
show the complexity of an issue.
• Feature abundance: while the basic
features are easy to use and apply, a
speaker can get carried away and try to
use all the features at once, rather
than to simply support a message. Too
many flying letters, animations, and
sound effects, without seeing much
original thought or analysis, can be a
real issue. In many cases, the medium
shoves the message aside.
Delivery
•

•
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Basic equipment required: you will
need to have a computer and
projection equipment in place to
display the slides to the audience.
Focus on the medium, not the
message: Too many people forget that
they are making a presentation first -and that PowerPoint is just a tool.

Ease of use:
User-friendly
Meets Accessibility Standards:
Fully Yes - If Captions are added (instructions on Keep Teaching site)
Integration with Bb: Yes, only the final product
which is MP4 video or MP3 audio.

Displayed easily: N/A

Works better with browser: N/A

Resources and additional help:
1.) Contrast color checker
2.) Tips for creating and delivering an effective presentation
3.) Record a slide show with narration and slide timing
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Scenario 2: Record a Full-Screen Lecture (Narrated Slides) – Camtasia
Software:
Camtasia

Platform:
Windows and Mac

Hardware:
Computer (Mac or PC)
Mic
Webcam

Tablet

Cost:
Free
Prepare Your Content!

Here are some tips to help you record a full screen lecture video for your
class:
Chunk your lecture into short 5 to 10 minute segments. Not only
are shorter videos easier for you to upload, but people also have
shorter attention spans online.
Observe copyright laws for both images and text content. Use
Creative Commons for restriction-free images.
For visual accessibility, be sure you have good color contrast
between your background and fonts.
Don’t use background images.
Choose large, legible fonts: stick with sans-serif fonts (Calibri or
Arial instead of Times New Roman, e.g.) and use 20-40pt sizes that
are easy to read. Bold and italics should be used for emphasis only.
ALL CAPS is reserved for acronyms.
When designing slides, use the 7x7 Rule: no more than seven lines,
with seven words across. Keep slide designs clean. Follow a logical
sequence in your content.
Plan your scripts ahead of time. Speak clearly.
Practice, practice, practice!

Where to download?

Camtasia. Keep in mind that the link is for educational pricing per user. This
is a paid software.

What to do?

Use 1: Record full screen lecture
Use 2: Annotations, callouts, custom visuals
Use 3: Video editing, Highlight, audio mix etc.

How to install?

Installation guide:
PC Installation
Mac Installation
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How to use?
Step 1

Record a Full-Screen Lecture (talking head). To begin, click and open
Camtasia from your desktop/your installed location.
To start a recording, click the Record button at the top of the tools panel.
This opens the Camtasia recorder which, by default, is set to capture
everything that happens on your screen.

Step 2

Customize Recording Settings.
#1 Choose to record the full screen or select a custom region to record.
#2 Choose other
inputs to record
along with the
screen. Options
include webcam,
microphone audio,
and system audio.
Select the down
arrow or the
double arrows next
to each to choose
a specific
microphone or
webcam.
#3 Click Start Recording to begin.

Step 3

Finish Recording (Windows)
When you’re finished recording, click the Camtasia recorder icon in the
taskbar, then the Stop button. If you need to re-record, choose delete to
start over.
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Quick Tip: Press “F10” to stop a recording, or “F9” to pause/resume a
recording.

Finish Recording (Mac)
To finish the recording, click the Camtasia icon in the Apple menu bar, then
click “Stop Recording.” Or, if you need to re-record, choose “Start Over.”

Quick Tip: Press “CMD+OPTION+2” to stop a recording, or “CMD+SHIFT+2”
to pause/resume a recording
Step 4

Trim out Mistakes
Often, we record a little extra at the beginning and at end of a recording. To
remove the extra content, drag the end of the clip “in.” This is called
trimming. If you trim too much, drag the clip back to restore your video.
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It’s good to note that any edits you make on the timeline won’t affect your
original recording in the media bin.
Cut out Mistakes
Drag the red or green handle on the playhead to select the area to remove,
then click the cut button to remove the section. A stitched line will appear
to show you where the cut was made.
If you make a selection and want to bring the playhead back together,
double click the playhead.

Add Titles, Annotations, Effects & More
Add a level of polish and professionalism to your videos with eye-catching

titles, annotations, effects, and more. Click and drag them from the tools
panel to the timeline or canvas.
Step 5

Export & Share.
When you’re ready to export or share your video, click the Share button in
the upper right corner of the editor, then select a destination.
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Tips and Tricks

•

•

•

•

Add an eye-catching intro. Start your training videos with an
attention-grabbing intro from the Camtasia Library. These intros
are fully customizable, and they can quickly add a level of
professionalism to the learning you’re about to provide. To
download Library assets, visit library assets.
Add transitions to improve flow. Use transitions between scenes
and slides to improve the flow of your training videos. Camtasia
makes it easy to quickly add transitions and then customize them
with a broad array of creative options.
Use animations to make your training videos come alive. Grab
your viewer’s attention with fun, professional animations that
require minimal effort for maximum impact. In Camtasia, we call
these animations “Behaviors”; they come ready-to-use and they
are fully customizable.
Set the tone with music. Music is a powerful tool for setting the
tone and mood of a training video. It’s also a great way to get your
viewers engaged while making the video a little more fun to watch.
However, keep in mind that you are creating the videos for an
educational purpose, so this might not be a good fit for your need.

Pros
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•

The interface itself is very intuitive.
The tools provided with Camtasia
allow users to do a lot with video, and
the way in which a user would
accomplish various tasks is pretty easy
to understand and execute.

•

•

Cons

•

•

•
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Camtasia comes with a set of "library
assets" which are templates, images,
motion graphics, and audio files that fit
together to create an overall style for a
video. Without a lot of experience
working with video, these help novice
designers develop a more polished
product more rapidly.
Compared to more robust software
platforms, like Adobe Premiere or Final
Cut, Camtasia lets people who don't
need that level of software deliver
high-quality video products quickly.
Camtasia isn't basic and it isn't robust but it certainly meets the need for the
price point.
Camtasia could do better on its keying
performance, which is the ability to
remove a specific color - for green
screen execution. It takes a little bit of
time to fine-tune the settings to get a
good quality color removal without
seeing grainy edges.
The ability to manipulate the video
with motion or rotation is slightly
limited in Camtasia. Other programs,
such as Adobe Premiere or Final Cut,
have a lot more flexibility with video
manipulation that isn't always
necessary in Camtasia; however, it
would be better to have a few more
options in this area.
Actual video editing - color correction,
for example - is very limited in
Camtasia. If you don't have a quality
team filming your videos, then live
action can become troublesome
without the ability to adjust the
footage, since the tools are so limited
in Camtasia related to that side of
post-production.

Ease of use:
User-friendly
Meets Accessibility Standards:
Fully Yes - If Captions are added (instructions on Keep Teaching site)
Integration with Bb: only the final product
which is MP4 video or MP3 audio.

Displayed easily

Works better with browser: N/A

Resources and additional help:
1. Link to online tutorials: More Information
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Scenario 2: Record a Full-Screen Lecture (Narrated Slides) - QuickTime Mac
Native
Software:
Native QuickTime

Platform:
Mac

Hardware:
Mic
Camera
Mac Computer

Cost:
Free

Prepare
Your
Content!

Here are some tips to help you record a full screen lecture video for your class:
Chunk your lecture into short 5 to 10 minute segments. Not only are shorter
videos easier for you to upload, but people also have shorter attention spans
online.
Observe copyright laws for both images and text content. Use Creative
Commons for restriction-free images.
For visual accessibility, be sure you have good color contrast between your
background and fonts.
Don’t use background images.
Choose large, legible fonts: stick with sans-serif fonts (Calibri or Arial instead of
Times New Roman, e.g.) and use 20-40pt sizes that are easy to read. Bold and
italics should be used for emphasis only. ALL CAPS is reserved for acronyms.
When designing slides, use the 7x7 Rule: no more than seven lines, with seven
words across. Keep slide designs clean. Follow a logical sequence in your
content.
Plan your scripts ahead of time. Speak clearly.
Practice, practice, practice!

Where to
download
What to do

Software already included on Mac desktop

How to
install
How to use
Step 1
Step 2

Software already included on Mac desktop

Use 1: Record full screen lecture

Open PowerPoint presentation
Using Screenshot in the QuickTime Player app, you can make a video recording of your
computer screen. You can open the recording in the app and save it on your Mac.
In the QuickTime Player app on your Mac, choose File > New Screen Recording to open
Screenshot and display the tools.
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Step 3

From there, you can use the pop-up menu, which appears to indicate which
microphone to use, where to save the file, and how long the timer will count down
before the recording starts.
You can click Options to control what you record. For example, you can set the
location where you want to save your screen recording or include the pointer or the
clicks in the screen recording.
You may have to approve/allow some access to your camera and microphone during
this process, but your Mac will walk you through it.
Click Record. To stop recording, click the Stop Recording button in the menu bar (or
use the Touch Bar).

Step 4

No editing capabilities.

Step 5

The screencast is saved as an MP4 file which all media players and video editing
applications can play.

Tips and Tricks

•

•

•
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On pre-Mojave machines, you can
capture screen recordings with the
QuickTime Player app, which comes
preinstalled on all Macs. (You can find it
in the Applications folder.) To record the
screen using QuickTime Player, launch
the app and choose File > New Screen
Recording from the menu bar.
Alternatively, you can use the ⌃⌘N
keyboard shortcut.
Next, you will see some on-screen
instructions. You will be asked either to
click anywhere to start recording the
entire screen, or to click and drag to
make a selection. If you opt to make a
selection, you get to keep trying until you
get a selection you like. When you’re
ready to record, click the Start Recording
button in the middle of your selection.
In either case, you can stop recording by
clicking the Stop button in the menu bar.

Pros

•
•
•
•
•
•
•

•

•

•

Cons

•
•

•

•
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Conversion of images to different
formats.
Being able to record Skype videos in
full screen.
Ability to save videos from the web.
Creation and editing of videos and
application of special FX.
MIDI input for synthesizers and
musical instruments.
The end user can be able to crop and
resize as well as edit all videos.
QuickTime will let you play videos that
are stored on your hard drive as well
as being able to stream content by
supplying the URL of the video source.
QuickTime improves security on the
web browser, whereby your content
updates on the web and the amounts
of visits are made secure by default.
Works perfectly with HD videos. You
can get to experience excellent video
quality and full HD movies.
Perfect for audio playback integration.
QuickTime offers audio integration
with your browser, thereby allowing
you to watch videos right away from
its window without having to go back
to the hard drive where it has been
saved.
Compared to other version of
QuickTime, this specific software
doesn’t have any additional features.
The end user must install extra codes
manually in order to be able to play
back some videos and audios.
Has no playback support system
especially for those file formats such
as AVI and FLV.
To run the application better, the end
user must install a bloatware
application that gets to take much of
your PC space and can cause problems
for other software updates and
applications.

Ease of use:
User-friendly
Meets Accessibility Standards:
Fully Yes - If Captions are added (instructions on Keep Teaching site)
Integration with Bb: only the final product
which is MP4 video or MP3 audio.

Displayed easily: N/A

Works better with browser: N/A

Resources and additional help:
1.) Online Tutorials
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Scenario 2: Record a Full-Screen Lecture (Narrated Slides) – Kaltura
Software:
Kaltura

Platform:
Windows and Mac

Hardware:
Mic
Camera

Tablet

Cost:
Free

Prepare
Your
Content!

Here are some tips to help you record a full screen lecture video for your class:
Chunk your lecture into short 5 to 10 minute segments. Not only are shorter
videos easier for you to upload, but people also have shorter attention spans
online.
Observe copyright laws for both images and text content. Use Creative
Commons for restriction-free images.
For visual accessibility, be sure you have good color contrast between your
background and fonts.
Don’t use background images.
Choose large, legible fonts: stick with sans-serif fonts (Calibri or Arial instead of
Times New Roman, e.g.) and use 20-40pt sizes that are easy to read. Bold and
italics should be used for emphasis only. ALL CAPS is reserved for acronyms.
When designing slides, use the 7x7 Rule: no more than seven lines, with seven
words across. Keep slide designs clean. Follow a logical sequence in your
content.
Plan your scripts ahead of time. Speak clearly.
Practice, practice, practice!

Where to
download?

Comes with the university LMS, Blackboard (Bb). You can only access it in Bb from
outside the course, from the Tools link in main menu.
Follow These Steps:
1. Select Tools on the Blackboard main navigation menu
2. Select My-Media on the Tools page
3. Select Add New > Screen Capture+

What to
do?
How to
install?

Use 1: Record full screen lecture
Use 2: Record talking head with lecture slides
Use 3: Upload/integrate directly with LMS (Bb)
Installation guide:
After following the three steps listed under “where to download/get”, follow these
steps:
4. In the Launch Application windows, select Kaltura Capture and then Open Link.
Please use the appropriate Download link, shown below, to install the application.
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How to use
Step 1:
Record
Yourself

After Step 4 from “How to install”, follow these steps to record the screen:
5. Check the camera, screen, and audio settings and change as needed for your system
6. Allow Camera to capture your video. Select the red Record button to begin.

7. Begin recording after the countdown expires
8. Use the Recorder control to pause, stop, and even annotate your video
9. Select the square Stop button when the recording is complete
10. Review the video playback
11. Add a title, then select Save & Upload
12. Close the Kaltura Capture window
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Step 2:
Sharing
Your
Videos

Follow These Steps:
1. Navigate to the content area where the video will be located
2. Under the Build Content menu, select Kaltura Embed

3. Locate the video to be added, then select the Select button
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Step 3:
Creating a
Course
Media
Gallery
Menu Link

Follow These Steps:
1. Select the Add Menu Item button on the course menu, then select Tool Link

2. Enter the name for the menu item—e.g., Course Videos
3. Select the type to be Media Gallery
4. Check the Available to Users box
5. Select Submit
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Step 4:
Making
your
Videos
Accessible

Add transcripts to improve the user experience and to appeal to a broader audience
Add captioning to improve user focus and recall
How do I request caption/transcript services to videos?
Adding a Transcript:
Follow These Steps:
1. Navigate to the content area where the video is located
2. Select the Dropdown Arrow next to the video title
3. Select Edit > Browse My Computer to choose the document
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4. Once the document has been selected, change Link Title to the document name
5. Select Submit

Adding Captioning:
Follow These Steps:
1. Select Tools on the Blackboard main navigation menu to access the video from in the
media repository
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2. Select My-Media on the Tool page

3. Select the Pencil Edit Icon to view the video options > Select the Captions tab >
Select the Upload captions file button to open the Upload a captions file window

4. Select Browse to choose the SRT file. When the SRT file is selected, Upload
Completed! will appear
5. Select Language > type in Label “CC” > Select Save
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6. The SRT is added

Tips and Tricks

•
•

•
•
•

Add videos to present topics with which students often have
difficulty.
Use a mix of video resources: ones that you create, and ones
created by others. Use short (5- to 10-minute) videos to review
topics.
Create a script when making your own videos.
Consider whether external videos might be copyrighted.
Find video resources that support ADA-508 requirements, such as
captioning.

Pros

Cons

•
•
•
•
•
•

26 | Center for Learning and Teaching | ODU | 2020

Comes with LMS (Bb). Free.
Can be used for quiz builder from the
videos.
Directly integrated with Blackboard.
May be a little confusing for the
beginner.
Video editing functionalities are limited.
If you change your institution/university,
you need to download and save it for
future re-use. Cannot be just transferred
directly from one LMS to another.

Ease of use:
User-friendly
Meets Accessibility Standards:
Fully Yes - If Captions are added (instructions on Keep Teaching site)
Integration with Bb: only the final product
which is MP4 video.

Displayed easily: N/A

Works better with browser: N/A

Resources and additional help:
1. Link to online tutorials: Online Tutorials
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